Welcome to DirectUpdate

DirectUpdate is a dynamic dns client updater.

Its main goal is to periodically detect your IP address and update it to your dynamic dns services.

Help contents:

  • Getting started
    • to be done
DirectUpdate - Copyright © 2000-2001, William Levra-Juillet.


Introduction

DirectUpdate allows you to associate a dynamic IP address with a static hostname, and to keep it updated whenever you log onto your ISP.
Thus you can have a home ISP account with a dynamic IP address for each login, and still run a Web server, BBS, broadcast mailer, or other Internet service without permanent, dedicated access.
Advanced features of DirectUpdate include:

  • Running as a native NT service
  • Remote administration
  • Local and remote IP detection
  • E-mail notification
  • Very small (less than 200KB) service footprint.

Once DirectUpdate is running, it allows to you maintain a more permanent Web presence.

DirectUpdate is made of three parts:

  • The engine is the main part. It's the NT service doing the job.
  • The admin is the visible part (the UserInterface).
  • The control is a small tool (running in the icon tray) to start/stop the engine.


DirectUpdate - The engine

The engine

The engine is the main part of DirectUpdate.

It has almost no User Interface but it's the part doing all the job !

You access it and configure it using the admin part.


DirectUpdate - The administration module

The administration module

The admin module is the visible part of Directupdate.
You are managing the settings using this module.

First you have to connect to the machine runningthe DirectUpdate engine.
Go to the first tab "Engine connection", and fill the field "connect to machine:"
Usually, the engine is running on the same machine, so select "localhost" (it's the same as typing "127.0.0.1").

Then click on connect ! If the engine is running on the machine, you should be connected.

For security reasons, you have to provide a password. Anyway, by default this password is blank.
A warning in the log file will be added, to tell you to change the password.

To change the password, click on "Change password..." button (note that of course you have to be connected to the engine).


DirectUpdate - Supported services

Supported services

DirectUpdate can only works if you have one or more dynamic dns accounts.
At the time of this help file, supported dynamic dns services are:

dyndns.org
Yi.org
DtDNS
HammerNode (HN.org)
EyeP.net
dynu.com
easyDns
No-IP.com
dyns.cx
dnsQ.org
myIP.org
ns1.net
ZoneEdit
dyn.ee
Central Informations Services
Nikhilino Online Systems (NOLS.com)
dhs.org
YYweb.com
dyn.ca

These services are sorted by chronological support in DirectUpdate.
If you'd like to see another service supported in DirectUpdate, please, let me know.

However, some services, voluntary asked me not to support them :
DNS2go.com


DirectUpdate - dyndns.org

dyndns.org service

Dyndns.org was the first service supported by DirectUpdate.
The page about client updater is amazing ! Check it out and vote for DirectUpdate :)

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.dyndns.org" or "mydomain.homeip.net".

Username: your dyndns username.

Password: your dyndns password.

Advanced settings:

Enable wildcard: check this box to be able to use *.mydomain.dyndns.org and not only mydomain.dyndns.org

MX domain: enter here the server address for your MaileXchanger (leave blank if unknown).

Backup MX: Check this box if the above address is your secondary MX (it means mydomain.dyndns.org will be your primary MX).

For more info, visit the dyndns support pages.


DirectUpdate - yi.org

yi.org service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.yi.org".

Username: your yi username.

Password: your yi password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

No support available at this time.


DirectUpdate - DtDNS service

DtDNS service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.dtdns.net" or only the host, like "mydomain".

Username: not required.

Password: your dtdns password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the easydns support pages.


DirectUpdate - HammerNode

HammerNode service

Settings:

Domain: not required. Will be "username.hn.org".

Username: your hn username.

Password: your hn password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dtdns support pages.


DirectUpdate - EyeP.net

EyeP.net service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.eyep.net" or "mydomain.fake.cx".

Username: your eyep username.

Password: your eyep password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

No support available at this time.


DirectUpdate - dynu.com

DynU.com service

Settings:

Domain: require ONLY the host name like "mydomain" (without .dynu.com).

Username: not required.

Password: your dynu password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dynu support pages.


DirectUpdate - EasyDNS

EasyDns.com service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.com" or "www.mydomain.com".

Username: your easydns username.

Password: your easydns password.

Advanced settings:

Enable wildcard: check this box to be able to use *.mydomain.dyndns.org and not only mydomain.dyndns.org

MX domain: enter here the server address for your MaileXchanger (leave blank if unknown).

Backup MX: Check this box if the above address is your secondary MX (it means mydomain.dyndns.org will be your primary MX).

For more info, visit the dynu support pages.


DirectUpdate - no-IP.com

No-IP.com service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.no-ip.org" or "myname.servequake.com".

Username: your no-ip username.

Password: your np-ip password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the no-ip support pages.


DirectUpdate - dyns.cx

DyNS.cx service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.dyns.cx" or "mydomain.com".

Username: your dyns username.

Password: your dyns password.

Advanced settings:

Enable wildcard: Not supported (always ON).

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dyndns support pages.


DirectUpdate - dnsQ.org

dnsQ.org service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.dnsq.org".

Username: your dnsq username.

Password: your dnsq password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dnsq support pages.


DirectUpdate - myIP.org

myIP.org service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.myip.org".

Username: your myip username.

Password: your myip password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the myip support pages.


DirectUpdate - ns1.net

ns1.net service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.x.ns1.net" or "mydomain.dyn.technowhore.com".

Username: your ns1 username.

Password: your ns1 password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

No support page available at this time.


DirectUpdate - ZoneEdit.com

ZoneEdit service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.org" or "ftp.mydomain.com".

Username: your zoneedit username.

Password: your zoneedit password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the zoneedit support pages.


DirectUpdate - dyn.ee

dyn.ee service

Settings:

Domain: not required. Will be "yourname.dyn.ee".

Username: your dyn.ee username.

Password: your dyn.ee password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dyn.ee support pages.


DirectUpdate - Central Info Services

Central Information Services service

Central information Services is not providing dynamic dns anymore.

For more info, visit the cis support pages.


DirectUpdate - nols.com

Nols service

Settings:

Domain: not required. Depends of your username.

Username: your nols username.

Password: your nols password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the nols support pages.


DirectUpdate - dhs.org

dhs.org service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "myname.2y.net".

Username: your dhs username.

Password: your dhs password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dhs support pages.


DirectUpdate - yyweb.com

YYweb.com service

Settings:

Domain: require the "fully qualified domain name" (fqdn), like "mydomain.org" or "ftp.mydomain.com".

Username: your yyweb username.

Password: your yyweb password.

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the yyweb support pages.


DirectUpdate - dyn.ca

dyn.ca service

Settings:

Domain: Not required. Will be ""yourname.dyn.ca".

Username: your dyn.ca username.

Password: your dyn.ca password.

WARNING: The dyn.ca update protocol doesn't allow DirectUpdate to specify the IP address.
Dyn.ca will try to automatically detect your IP... (The IP detected by DirectUpdate is ignored although it triggers the update).

Advanced settings:

Enable wildcard: Not supported.

MX domain: Not supported.

Backup MX: Not supported.

For more info, visit the dyn.ca support pages.


DirectUpdate - F.A.Q.

F.A.Q. - Frequently Asked Questions

to do...


DirectUpdate - Common problems

Common problems

  • The update failed with error 400 - HTTP invalid syntax.
    • Be sure you have no special characters in your username and/or password.


DirectUpdate - Report

Reporting

You have a comment, a remark. You think a feature is missing or you think you found a bug ?
Whatever, never hesitate to contact me at willynt@directupdate.net.

Please, provide as more informations as possible.Like:
- Your order notice number (STxxx) or serial number if you are a registered user.
- The DirectUpdate version you are using.
- Your internet configuration (xDSL, ISDN, via modem or router, ...)
- An exact description of the problem (if any :)) and a way to reproduce it (if possible)

I do my best to reply quickly to every message I receive...
If I didn't reply in 3 or 4 days, resent your message :)


DirectUpdate - Registration

Registration

Why registering DirectUpdate ?
Simply because I spend a lot of time and money to develop and improve this product.

DirectUpdate is released as a shareware, but you can evaluate it for as long as you want.
Without ANY restrictions !

I only popup a little "register" dialog box to remind you I need your money to buy a new Porsche :)
(kidding...)

More seriously, by registering DirectUpdate, you will help me to continue my efforts to improve it.
Do not forget it's a life time registration !

Ok, you convinced me, I want to give you my money...


DirectUpdate - About

About page

xxx


DirectUpdate - Advanced settings

Advanced settings page

xxx


DirectUpdate - Log page

Log page

xxx


DirectUpdate - Register

Register page

xxx


Directupdate - Settings page

Settings page

xxx


DirectUpdate - Status page

Status page

xxx


DirectUpdate - Account advanced settings

Account advanced settings

xxx


DirectUpdate - Account locked

Account locked

xxx


DirectUpdate - Account settings

Account settings

xxx